如何在 Ubuntu 14.04 LTS 上为 Node.js 安装 NVM

Node 版本管理器允许管理员轻松管理 node.js 版本。 它是 bash 具有管理能力的脚本 node.js 的活动版本,具有安装、使用特定 node.js 版本执行命令、设置 PATH 变量以使用特定 node.js 版本等功能。

飞行前检查

  • 这些说明专门用于在单个 Ubuntu 14.04 LTS 节点上安装 NVM(节点版本管理器)。
  • 我将在 Liquid Web Core Managed Ubuntu 14.04 LTS 服务器上工作,我将以 root 身份登录。

第 1 步:安装 C++ 编译器

作为最佳实践,我们将更新我们的包:

apt-get update

构建必备 包应该已经安装了,但是,我们仍然将它包含在我们的安装命令中:

apt-get install build-essential libssl-dev

步骤 #2:安装 NVM(节点版本管理器)

使用以下 curl 启动安装脚本的命令:

curl https://raw.githubusercontent.com/creationix/nvm/v0.25.0/install.sh | bash

在发布时, NVM v0.25.0 是可用的最新版本。 你应该检查 NVM 最新版本的 GitHub 项目页面,并调整上述命令以包含最新版本。 为了 example,如果最新版本是 0.30.2,那么您的命令将类似于:

curl https://raw.githubusercontent.com/creationix/nvm/v0.30.2/install.sh | bash

运行上述命令后,您可能会收到类似于以下内容的输出:

Close and reopen your terminal to start using nvm

要么按照输出建议做,要么 close 并重新打开您的终端会话,或运行以下命令:

source ~/.profile

步骤 #3:验证安装

我们可以使用以下命令快速验证 NVM 现在是否已安装并正常工作:

nvm --version

在这种情况下会产生以下结果:

0.25.0

另一个非常有用的命令可以帮助您开始 node.js 管理:

nvm help